Entering credit card information is failing for some customers
Incident Report for Atlassian Statuspage
Resolved
This incident has been resolved.
Posted Jan 18, 2021 - 20:07 PST
Identified
We have identified the problem as being a recent change to our front-end billing components and are rolling out a fix now.
Posted Jan 18, 2021 - 17:59 PST
Investigating
We are investigating an issue with providing credit card information that is impacting some customers who have signed up recently.

Customers with existing payment arrangements are not affected.
Posted Jan 18, 2021 - 16:43 PST
This incident affected: Management (Billing).