Latency in System Metrics

Incident Report for Atlassian Statuspage

Resolved

The latency fix is confirmed stable across all integrations, and we are closing this issue as resolved.
Posted Mar 27, 2026 - 00:08 PDT

Update

The latency fix is confirmed stable across all integrations, and we are closing this issue as resolved.
Posted Mar 27, 2026 - 00:08 PDT

Monitoring

The latency-reduction fix for system metrics has been deployed, and we are actively monitoring its performance.
Posted Mar 20, 2026 - 06:39 PDT

Investigating

We are investigating a processing delay affecting system metrics. We are working on a fix and will update you shortly.
Posted Mar 19, 2026 - 15:52 PDT
This incident affected: System Metrics (Pingdom Integration, New Relic Integration, Datadog Integration, Custom Integration).