Issues setting up SSL on new pages
Incident Report for StatusPage.io
Resolved
New pages that have enabled SSL have now been verified and this issue has been resolved. SSL is working as expected.
Posted 4 months ago. Apr 24, 2017 - 15:01 PDT
Update
We're working with our SSL provider to resolve this and we will update this incident once we have more information.
Posted 4 months ago. Apr 24, 2017 - 09:45 PDT
Investigating
We're experiencing issues with our SSL provider which is causing self-service SSL enablement to fail. This is only impacting new status pages that enable SSL. Existing pages with SSL are not affected. We encourage new pages to refrain from setting up SSL until we're able to resolve this with our SSL provider.

We'll update this incident once we have additional information.
Posted 4 months ago. Apr 21, 2017 - 14:29 PDT
This incident affected: SSL Provisioning.