Email Delivery Delays
Incident Report for StatusPage.io
Resolved
We're now routing all mail through another provider as a precaution. All mail should be delivered as normal. Once our other mail provider reports stability, we will go back to routing mail 50/50 through both providers.
Posted 10 months ago. Sep 13, 2016 - 11:35 PDT
Monitoring
One of our mail providers has reported delays. We are monitoring the issue and are prepared to route all emails through another provider if necessary.
Posted 10 months ago. Sep 13, 2016 - 10:25 PDT
This incident affected: Notifications (Email).